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Objective 
In this lab, you will learn about RF and microwave filters including: 

1. Ideal filter response versus real world 

2. Common filter technologies used in industry (close-up and In-production assembly) 

3. Filter companies and types of filters offered 

4. Filter specifications 

After this introductory information about filters, you will use a design specification as you design, synthesize, 
simulate, build and verify performance: 

5. The Engineering Challenge – Decision Tree 

6. Steps to design a custom filter (168.5 MHz lumped element filter) 

a. Determine specifications from system requirement 

b. Synthesize (Genesys Synthesis) 

c. Simulate (ADS/Momentum and EMpro) 

d. Prototype / Tune (X-MWblock on Prototype Station) 

e. Measure (FieldFox) 

f. Compare synthesis, simulation, and measurements to specification 
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Pre-Lab Setup Instructions 
1. Prepare the required items as listed in “Equipment Required” and “Accessories Required” below. 

2. Ensure the required software has been downloaded according to the “Software Required” list and install 
them on your Windows PC. 

3. If you are using this lab as a print out, please copy the following files that are used in this lab to your 
computer: 

− Lab2GENESYSworkspace.wsg 
− Lab2workspace_wrk.7zads 

4. The compressed .7zads folder should be de-compressed using File > Unarchive… from the ADS Main 
window to the root of the C:\ drive on your computer: 

− Lab2workspace_wrk.7zads 

Equipment Required 
1. A PC running Windows with internet access 
2. Keysight FieldFox with Network Analyzer (NA) with options 210 and 211, 18 GHz or higher frequency. A 

bench NA with similar specifications may be substituted. 

Accessories Required 
1. X-Microwave Prototyping Plate, Screws, 1/16-inch Allen Wrench 
2. Two X-MWprobe SMA connectors 
3. X-MWblock filters 

a. LTCC Band Pass Filter, BFCN-1860+, XM-A6Y2-0204D, PCB #0029 
b. BAW Filter Centered at 1842.5GHz, TQQ0303, XM-B1F3-0404D, PCB #0473 
c. SAW Filter Centered at 168.5 MHz, 856512, XM-A3V3-0404D, PCB #0412 
d. Lumped Low Pass 168.5 MHz + 45MHz, XM-B1F4-1204D, PCB #0976 

 

 
Figure 1. Accessories Required 
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Recommended Tools 
1. 1/16-inch US Allen wrench 
2. Fine tweezers 
3. Straight pick  
4. Sticky “jewel picker” stick 

 
 
 

Software Required 
1. Keysight PathWave GENESYS  
2. Keysight PathWave ADS with Momentum  
3. Keysight PathWave EMPro  
4. Keysight FieldFox Data Link 
5. Keysight PathWave BenchVue (optional) 

 

Pre-study reading and viewing 
1. Introduction to Genesys:   

https://www.keysight.com/en/pc-1297125/genesys-rf-and-microwave-design-software?nid=-
34275.0.00&cc=US&lc=eng  

2. Filter Synthesis (Genesys Synthesis):   
https://youtu.be/6sWroyFNlS8 

3. Linear Simulation in Genesys:   
https://www.youtube.com/watch?v=DqNlMTSPQjA  

4. Optimizing Filter Performance Using Integrated 3D EM Simulation:  
https://youtu.be/Z3dhIf1ruvc 

5. X-MWSYSTEM Getting Started Documentation:  
https://www.xmicrowave.com/x-mwsystem/documentation/ 

 

https://www.keysight.com/en/pc-1297125/genesys-rf-and-microwave-design-software?nid=-34275.0.00&cc=US&lc=eng
https://www.keysight.com/en/pc-1297125/genesys-rf-and-microwave-design-software?nid=-34275.0.00&cc=US&lc=eng
https://youtu.be/6sWroyFNlS8
https://youtu.be/6sWroyFNlS8
https://www.youtube.com/watch?v=DqNlMTSPQjA
https://youtu.be/Z3dhIf1ruvc
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1 Background 
RF and microwave filters are one of the most common building blocks of signal processing systems. They pass 
desired signals in a range of frequencies known as a passband, and they reject unwanted signals outside of the 
passband. 

The four most common filter types are as follows.  

Filter Type Description 

Low Pass Filter 
Passes low frequencies and rejects high frequencies. It is most often described 
using its 3-dB corner or cutoff frequency. The insertion loss increases 
dramatically above the cutoff frequency. 

High Pass Filter 
Passes high frequencies and rejects low frequencies. It is most often described 
using its 3-dB corner or cutoff frequency. The insertion loss increases 
dramatically below the cutoff frequency. 

Band Pass Filter 

Passes frequencies within a defined band and rejects lower and higher 
frequencies. It is most often described using a center frequency and 3 dB 
bandwidth of the pass band. The insertion loss (rejection) increases dramatically 
above and below the 3-dB bandwidth. 

Band Stop Filter 
(Notch Filter) 

Blocking a single frequency or band of frequencies, often used to reject one or 
more interfering tones. It is most often described using a center frequency and 
3-dB bandwidth of the reject band. The insertion loss (rejection) decreases 
dramatically above and below the 3-dB bandwidth. 

 
Here are ideal response plots of each filter type: 

 
 
 
More realistic and detailed response plots of simple first-order mathematical implementations are shown next.   

Of course, there is no such thing as an ideal filter that obeys its mathematical design exactly and pass and stop 
band responses vary. The real-world responses of low pass and band pass filters obtained from network analyzer 
screenshots are shown after the mathematical designs. These two screenshots show Gain (in blue) and Input 
Return Loss (in yellow). You will learn more about Return Loss and these measurements in this lab.  
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LOW PASS FILTER    HIGH PASS FILTER 

 
 

BAND PASS FILTER    BAND STOP FILTER 
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2 Filter Specifications 

Specification (Unit) Description 

Passband (Hz) The range of frequencies that pass through the filter with minimal attenuation or 
reflection. 

Stopband (Hz) The range of frequencies that are blocked by the filter typically with increased 
attenuation and reflection. 

Insertion Loss (dB) Amount of loss in the passband of the filter. This is often specified as rejection 
relative to the passband insertion loss. 

High Side Rejection (dB) Magnitude of attenuation in the stop band at frequencies on the high side of the 
passband. 

Low Side Rejection(dB) Magnitude of attenuation in the stop band at frequencies on the low side of the 
passband. 

Passband Ripple (dB) Peak-to-peak variation within the passband. 

Shape Factor A measure of the filter’s selectivity. It is the ratio of a filter’s 60-dB attenuation 
bandwidth to its 6-dB attenuation bandwidth. 

Group Delay The time it takes for signals to propagate through the filter, which may vary 
based on frequency. 

Reoccurring Passband  Higher frequencies where a low pass or band pass filter fail to attenuate signals. 
This often occurs at a harmonic of the desired passband. 
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3 Common Filter Technologies (Physical Types and Attributes) 

 
Technology Close-Up Example In-Production Assembly 

Low Temperature Co-
Fired Ceramic (LTCC) 
 
− 40 MHz to 12 GHz 
− Very small size 
− Minimal rejection 
− $2 to $6 

 
 

 

 

 
 

Lumped Element 
 
− 10 MHz to 12 GHz 
− Small size 
− High rejection 
− $50 to $500 

 
   
Ceramic 
 
− 100 MHz to 6 GHz 
− Moderate size 
− Moderate rejection 
− $50 to $400 

 
  

Cavity 
 
− 2 to 40 GHz 
− Large size 
− Very high rejection 
− $300 to $1000 
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Planar 
 
− 2 to 50 GHz 
− Very small size 
− High rejection 
− $50 to $300 

  

Tubular 
 
− 10 MHz to 10 GHz 
− Large size 
− Very high rejection 
− $300 to $600 

    

 

  
 

SAW / BAW (Surface 
Acoustic Wave / Bulk 
Acoustic Wave) 
 
− 100 MHz to 3 GHz 
− Very small size 
− Very high rejection 
− $10 to $200 

 

 
 

 

Suspended Substrate 
 
− 2 to 50 GHz 
− Medium size 
− Very high rejection 
− $200 to $800 

  

Waveguide 
 
− 2 to 100 GHz 
− Large size 
− Very high rejection 
− $200 to $2000 

  

Tunable 
 
− 100 MHz to >10 GHz 
− Very large size 
− Very high rejection 
− $1000 to $5000 
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4 Filter Companies 
Exercise:  Complete the table by researching the filter types in the vacant rows. 

Instructor Answers embedded in table.  
 

Company Info: 
 
Name 
Website 
 

LT
C

C
 

Lu
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d 
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em

en
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ic
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av

ity
 

Pl
an

ar
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bu
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W

 / 
B

A
W

 

Su
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de

d 
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tr

at
e 

W
av

eg
ui

de
 

Tu
na

bl
e 

K&L Microwave 
klmicrowave.com 

X X X X X X X X X X 

Lorch Microwave 
http://www.lorch.com/  

 X X X  X   X X 

Lark Engineering 
http://larkengineering.com  

  X X    X   

Reactel 
https://reactel.com  

 X X X     X  

Mini-Circuits 
https://www.minicircuits.com  

X X X X X X     

Q Microwave 
http://qmicrowave.com  

 X X        

DLI 
http://www.knowlescapacitors.
com/Company.aspx#dielectric  

   X X      

Marki Microwave 
https://www.markimicrowave.c
om/  

    X      

Qorvo 
https://www.qorvo.com/product
s/filters-duplexers/rf-filters  

      X    

 

http://www.klmicrowave.com/index.php
http://www.lorch.com/
http://larkengineering.com/
https://reactel.com/
https://www.minicircuits.com/
http://qmicrowave.com/
http://www.knowlescapacitors.com/Company.aspx#dielectric
http://www.knowlescapacitors.com/Company.aspx#dielectric
https://www.markimicrowave.com/
https://www.markimicrowave.com/
https://www.qorvo.com/products/filters-duplexers/rf-filters
https://www.qorvo.com/products/filters-duplexers/rf-filters
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5 The Engineer’s Challenge  
The engineering objective for most RF and microwave system designs is to design a system that meets all the 
specifications with reasonable margin and is manufacturable at the lowest cost within the allocated time. This 
requires swift development of clever solutions. You will soon discover that in microwave engineering every problem 
has many possible solutions. As you learn the tricks of the trade, master the tools, and gain experience you will get 
better and faster at achieving that clever design. You are probably asking yourself, “How do I start the design 
process?”.  

5.1 Single Mixer Converter Design Example 
Objective: Design bandpass filters for the 5G band n3 downlink (1842.5 MHz center) to a first intermediate 
frequency (IF, 168.5 MHz center) using the receiver topology shown in Figure 2. 

  
Figure 2. Single Mixer Converter Symbolic Block Diagram 

  
Figure 3. Single Mixer Converter Layout View  
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5.2 RF and IF Filter Design Specifications 
Your design will be based on 5G specifications from this table.  
Table 1. 5G Specifications 

Band Duplex 
mode 

ƒ 
(MHz) 

Common 
name 

Subset of 
band 

Uplink [A 1] 
(MHz) 

Downlink [A 2] 
(MHz) 

Duplex 
spacing 
(MHz) 

Channel 
bandwidths [2]  
(MHz) 

n1 FDD 2100 IMT  1920 – 1980 2110 – 2170 190 5, 10, 15, 20 

n2 FDD 1900 PCS 
(Blocks A–F) n25 1850 – 1910 1930 – 1990 80 5, 10, 15, 20 

n3 FDD 1800 DCS 

 1710 – 1785 1805 – 1880 95 5, 10, 15, 20, 25, 30 

Source:  3GPP TS 38.101-1 Release 15 (2017-12) 
 
Table 2. 5G Receiver Requirement  

Parameter Filter Requirement 
RF Bandpass Specification  

Center Frequency (CF) 1842.5 MHz 

Insertion Loss at CF < 2 dB 

Passband Flatness Re CF +/- 30 MHz < 1 dB 

Rejection < 1785 and > 1920 MHz > 40 dB 

IF Filter Specification  

Center Frequency (CF) 168.5 MHz 

Insertion Loss at CF < 10 dB 

Passband Flatness Re CF +/- 12.5 MHz, sufficient to cover Ch BW to 25 MHz < 1 dB 

Rejection > 337 MHz (2 x 168.5 MHz) > 30 dB 
 

Note that the IF Filter is consistent with either a bandpass or lowpass design. 
 

https://en.wikipedia.org/wiki/Frequency
https://en.wikipedia.org/wiki/Frequency
https://en.wikipedia.org/wiki/5G_NR_frequency_bands
https://en.wikipedia.org/wiki/5G_NR_frequency_bands
https://en.wikipedia.org/wiki/5G_NR_frequency_bands
https://en.wikipedia.org/wiki/5G_NR_frequency_bands
https://en.wikipedia.org/wiki/5G_NR_frequency_bands
https://en.wikipedia.org/wiki/5G_NR_frequency_bands
https://en.wikipedia.org/wiki/Personal_Communications_Service
https://en.wikipedia.org/wiki/Personal_Communications_Service
https://en.wikipedia.org/wiki/Digital_Cellular_System
https://portal.3gpp.org/ngppapp/CreateTdoc.aspx?mode=view&contributionUid=RP-172475
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6 Filter Design  
Objective:  Evaluate off-the-shelf Filters for the Receiver design and design a Lumped Element Filter. 

Filter Design Decision Tree  
First, you will take the red path for two purchased filters, and then you will take the blue path for a fully designed 
filter, allowing you to compare synthesized, simulated and measured results to the design specification. 

 

 
Figure 4. Filter Design Decision Tree 

You will continue to refer to this diagram throughout the lab. The final solution must meet the design specification in 
all desired operating conditions. Therefore, it is important that your measured results match the synthesis and 
simulation results.  
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6.1 Evaluate Off-the-Shelf RF and IF Filter Choices 

6.1.1 Evaluate an LTCC Filter for the RF Filter 
In this lab exercise, you will learn how to analyze an off-the-shelf filter, selected by manufacturer data sheet. This is 
the red path on the left side of the decision tree. The RF bandpass filter specification requires 1842.5-GHz center 
frequency (5G Band n3 Downlink) with a need to reject out-of-band signals and to achieve a desired spectral purity.  

First, you will evaluate an LTCC filter and then compare it against alternatives.  

Start by downloading the data sheet for the Mini-Circuits BFCN-1860+ 

− Website: https://www.minicircuits.com/WebStore/dashboard.html?model=BFCN-1860%2B   

− Datasheet:  https://www.minicircuits.com/pdfs/BFCN-1860+.pdf 

Review the data sheet specifications against the requirements. Does the filter satisfy the requirements? 

Procedure to Measure the Filter Performance 
1. Turn on the FieldFox and open Network Analyzer (NA) mode. 

2. Connect the cables and configure the network analyzer for a S11 measurement. 

3. Calibrate (Full 2-Port Mechanical Cal) [Appendix A] for the Full Span of the FieldFox with 1601-point 
resolution. If recently calibrated, you may instead recall the calibrated FieldFox state WIDE created in 
Appendix A in the Transmission Line lab. A 201-point resolution will be sufficient. 

NOTE Your start and stop frequency may vary depending on the NA used. The N9917A FieldFox will 
use 30 kHz to 18 GHz. 
  

 

4. Ensure that the filter is attached to the prototyping plate:  XM-A6Y2-0204D, PCB #0029. 

5. Attach two X-MWprobes (See instructions from Lab 1) and connect the cables. 

 
Figure 5. Mini-Circuits LTCC Filter with X-MWprobe Installed 

6. You may find it useful to use Keysight BenchVue to record measurements.  For more information, see the 
Appendix in the first lab. 

7. Record numeric results on the table below. 

https://www.minicircuits.com/WebStore/dashboard.html?model=BFCN-1860%2B
https://www.minicircuits.com/pdfs/BFCN-1860+.pdf
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8. Press Frequency > Start and set to 1 GHz and Stop to 4 GHz to zoom into the pass band and take the 
key measurements. You should either re-cal or recall the calibrated FieldFox state 1842.5 created in 
Appendix A in the Transmission Line lab. 

9. Zoom in further in Freq and Scale if needed such that the passband fills at least 2 full grid units on the 
screen. Use the Markers to make the insertion loss measurements shown in the image below.  

a. Select Marker > Select Marker 1 > Normal. 
b. Use the dial to move it to the location on the plot. 

c. Note: It may be helpful to view the markers in a table. 

d. Repeat for all your key measurements as shown in Results. 

10. Record results on the table below. Insertion Loss is obtained from S21. 

Measurement Results 
Instructor Answer: 
Table 3. LTCC Filter Results 

Band Pass 
Filter 

Center 
Frequency CF 

Insertion 
Loss at CF 

Add Loss at 
1812.5 MHz re 
CF 

Add Loss at 
1872.5 MHz 
re CF 

Rejection at 
1785 MHz 

Rejection at 
1920 MHz 

Requirement 1842.5 MHz < 2 dB < 1 dB < 1 dB > 40 dB > 40 dB 

XM-A6Y2-
0204D  1.688 dB 1 dB 1 dB Same as Ins 

Loss 
Same as Ins 
Loss 

 

1. In what frequencies do you see a recurring passband? Hint: Less than 10 dB rejection. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Instructor Answer:  

 ~7.2 GHz. (CF x 4) 
~14.4 GHz (CF x 8) 

 
  Tan circles show recurring passbands  
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2. Would you select this this filter to provide 40 dB rejection below 1785 and above 1920 MHz? 

Instructor Answer:  

No. Since the passband extends to the required frequencies of rejection and the filter never actually 
achieves 40 dB rejection except below very low frequencies. 

3. Discuss S11 and S22 and display their Smith charts. To configure a Smith chart, got to Measure, select the 
Snn and change the Format to Smith. 

Instructor Answer: 

The previous Log Mag chart shows low reflection (high return loss) in the pass band indicating that power 
is being transmitted, but high reflection (low return loss) in the stop band indicating that power is being 
reflected rather than transmitted. Very similar S11 and S22 indicate a bilateral device. 

The Smith chart is graduated in Impedance instead of Return Loss. Scrolling the frequency marker along 
the Smith charts shows that the exact 50-ohm match is outside the passband, not necessarily a problem 
since the magnitude of impedance near the passband may still be close enough to 50-ohms to provide 
sufficient match. 
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4. How does this part compare to its data sheet? (Review the data sheet for the BFCN-1860+) 

 
 

Instructor Answer:  

While the values are similar, there is slightly greater insertion loss and seems to have a wider bandwidth. 
Also, the actual response is not symmetric as is shown in the data sheet page 2 figure showing typical 
frequency response. 

5. In a new ADS workspace, add a New Data Display Window. 

 
 

6. Save the measurement as an S2P file to the FieldFox Internal Device or USB Device, transfer to your 
computer using Keysight FieldFox Data Link (Send to PC) or a USB memory stick, then using the Data 
File Tool…, Read data file into dataset the S2P file from the FieldFox NA. In the screen capture below, 
the name of the dataset LTCC_WIDE. A sample LTCC.s2p is provided below. 

Using Keysight FieldFox Data Link:  Save, then Show, then Send to PC. 

        
Note about SnP or “Touchstone” Files: These files contain small-signal S-parameters described by 
frequency-dependent linear network parameters for 1- to 10-port components. 
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7. Plot the measured data by clicking the Rectangular Plot icon and selecting S11, S12, S21, and S22 from 
the LTCC_WIDE dataset. You may want to review the method in the previous lab.  

 
 

8. Read data file into dataset the S2P file from the manufacturer’s website. In the screen capture below, the 
name of the dataset is LTCC_BFCN. If you prefer, the manufacturer’s file:  BFCN-1860+_TB-
824+Unit1_with_Port_Ext.s2p is provided below. 

BFCN-1860+_TB-8
+Unit1 with Port E  

 
9. Repeat with Frequency > Start and set to 1 GHz and Stop to 4 GHz using the calibrated FieldFox state 

1842.5. 
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6.1.2 Evaluate a BAW Filter for the RF Filter  
Evaluate the BAW filter against the required RF Filter specification. Fill out the table below measured performance. 
Compare the results of the BAW filter to the LTCC.  

Start by downloading the data sheets for the Qorvo TQQ0303 BAW Filter:   

− Website:  https://www.qorvo.com/products/p/TQQ0303  

− Data sheet:  https://www.qorvo.com/products/d/da005775 

Procedure to Measure the Filter Performance 
1. Disconnect the SMA cables from the probe. 

2. Press Frequency > Start and set to 30 KHz and Stop to 18 GHz (Full Span) and take the key 
measurements. You should either re-cal or recall the calibrated FieldFox state WIDE created in Appendix A 
in the Transmission Line lab. 

3. Carefully remove each X-MWprobe and the RF BPF from the prototyping plate. If the filter is presently part 
of the 5G Receiver system, remove only X-MW anchors on top of it (leave the anchors in place and tight on 
the X-MWblocks on either side of the filter so that the Ground-Signal-Ground (GSG) jumpers are retained) 
and slowly slide it out, underneath and being careful not to damage the GSG jumpers. 

 

    
Figure 6.  Removing the RF BPF X-MWblock 

When you return and re-install the X-MWblock carefully slide it under the two GSG jumpers. 

WARNING While this procedure to remove a passive X-MWblock from between two others may be used 
on a passive device, it should not be attempted on an active device that has either a bias or 
control block below it as the pogo pin may be damaged. Those X-MWblocks can be 
removed by first removing the anchors from adjacent block and then lifting the board straight 
up off the X-MWplate. 
 

 

 

 
 
  

Leave tight 

Leave tight 

https://www.qorvo.com/products/p/TQQ0303
https://www.qorvo.com/products/d/da005775
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4. Ensure the BAW filter is attached to the prototyping plate and secured with 4 screws:  XM-B1F3-0404D, 
PCB #0473. Re-attach the probes and connect the cables.  

 
5. Measure using the same procedure as above. 

6. Press Frequency > Start and set to 1 GHz and Stop to 3 GHz to zoom into the pass band and take the 
key measurements. You should re-cal or recall the calibrated FieldFox state 1842.5 created in Appendix A 
in the Transmission Line lab. 

7. Record results on the table below and download and compare the measure versus the manufacturer’s S-
Parameters as in the previous task.  

Measurement Results 
Instructor Answer is embedded in the table below.   
Table 4. BAW Filter Results 

Band Pass 
Filter 

Center 
Frequency 
CF 

Insertion 
Loss at CF 

Add Loss at 
1812.5 MHz 
re CF 

Add Loss at 
1872.5 MHz 
re CF 

Rejection at 
1785 MHz 

Rejection at 
1920 MHz 

Requirement 1842.5 MHz < 2 dB < 1 dB < 1 dB > 40 dB > 40 dB 
XM-B1F3-
0204D  1.255 dB < .9 dB < .4 dB > 40 dB 

but… 
> 40 dB 
but… 

… rejection degrades substantially below 1700 and above 1920 
 

1. What frequencies do you see a recurring passband? 

Instructor Answer:  

There are no recurring passbands. 
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2. Would you select this this filter to provide 40 dB rejection below 1785 and above 1920 MHz? 

Instructor Answer:  

Maybe, provided the rest of the system can accommodate the “lobes” of degraded rejection below 1700 
and from 1925 to 2400. 
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3. Discuss S11 and S22 and the Smith chart. 

Instructor Answer:  

Very similar S11 and S22. There is low reflection (high return loss) in the pass band indicating that power is 
being transmitted, but high reflection (low return loss) in the stop band indicating that power is being 
reflected rather than transmitted. 

4. How does this part compare to its data sheet? (Review the data sheet for the TQQ0303.)  
 

 
Instructor Answer:   

Using the same procedures as the previous filter to overlay measured and manufacturer performance, it 
can be seen they are nearly identical except for out-of-band rejection. The 5 to 10 dB difference there is not 
likely material to the receiver design. 

https://www.qorvo.com/products/p/TQQ0303
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TQQ0303_003.s2
  

BAW_1842.5.s2
  

BAW.s2p
 

Note how the different frequency record lengths display differently. 
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6.1.3 Evaluate a SAW Device for the IF Filter  
Evaluate the SAW filter against the required Intermediate Frequency (IF) filter specification. Fill out the table below 
as you take the measurements.  

Start by downloading the Data sheet for the Qorvo 856512 

− Website:  https://www.qorvo.com/products/p/856512  

− Data sheet: https://www.qorvo.com/products/d/da002930 

Procedure to Measure the Filter Performance 
1. Disconnect the SMA cables from the probe. 

2. Press Frequency > Start and set to 30 KHz and Stop to 18 GHz (Full Span) and take the key 
measurements. You should re-cal or recall the calibrated FieldFox state WIDE created in Appendix A in the 
Transmission Line lab. 

3. Carefully remove each X-MWprobe and return the BAW filter to its original position on the prototyping plate. 

4. Since the SAW filter XM-A3V3-0404D, PCB #0412 is presently part of the 5G Receiver system, remove 
only X-MWanchor on top of it (leave the anchor in place on the X-MWblock adjacent to the SAW filter so 
that the GSG jumper is retained) and slowly slide it out, underneath and being careful not to damage the 
GSG jumper. 

 
 
  

https://www.qorvo.com/products/p/856512
https://www.qorvo.com/products/d/da002930
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5. Rotate 90 degrees and place the SAW filter to the right of its original position so that two X-MWprobes can 
be attached on either side. 

 

 
6. Attach two X-MWprobes and measure using the same procedure as before.  

NOTE When you return and re-install the X-MWblock carefully slide it under the GSG jumper. 
 
  

 
7. Press Frequency > Start and set to 50 MHz and Stop to 350 MHz to zoom into the pass band and take 

the key measurements. You should re-cal or recall the calibrated FieldFox state 168.5 created in Appendix 
A in the Transmission Line lab. 

8. Record results in the table below and download and compare the measure versus the manufacturer’s S-
Parameters as in the previous task.  
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Measurement Results 
Instructor Answer is embedded in the table below.   
Table 5. SAW Filter Results 

Band Pass 
Filter 

Center 
Frequency CF 

Insertion Loss 
at CF 

Loss at 156 
MHz re CF 

Loss at 181 
MHz re CF 

Rejection at 
337 MHz 

Requirement 168.5 MHz < 10 dB < 1 dB < 1 dB > 30 dB 

XM-A3V3-
0404D  8.75 dB 1 dB 1 dB > 50 dB 

 
1. Would you choose this filter to provide 30 dB rejection above 337 MHz (2 x 168.5)? 

Instructor Answer:  

Yes. 
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2. How might this part’s insertion loss affect the design of the single mixer converter? 

Instructor Answer:  

The insertion loss may be too high, > 8 dB. 

3. How does this part compare to its data sheet? (Review the data sheet for the Qorvo 856512.) Compare 
passband and stop band performance. 

 

SAW_168.5.s2p 856512NM.S2P
 

 
Instructor Answer:  

Measured performance is very similar to datasheet and the manufacturer’s data. 

https://www.qorvo.com/products/d/da002930
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6.2 Design a Lumped Element Low Pass Filter for the IF Filter 
Now taking the right blue path in the decision tree, you will design a 190 MHz LPF to meet the IF Filter 
specification. This is because the existing SAW Filter’s high insertion loss might affect the design of the single 
mixer converter. You will synthesize a Lumped Element Filter and then compare the simulated results to actual 
measurements. Then you will have a chance to tune the filter for improved performance. 

The Filter X-MW PCB used for this exercise will be #0976. Note that in this case two capacitors are sometimes 
used to allow fine tuning of the capacitance per pad. 
 

 

Figure 7. Lumped Element X-MWblock, PCB 0976 

For the purposes of this lab, you will use the filter without the housing.  

 
Figure 8. Lumped Element Filter 
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In this lab, you will utilize Keysight Genesys to synthesize a filter and ADS to simulate its behavior. Keysight 
Genesys employs different types of simulation including Linear, RF System (Spectrasys), and Harmonic Balance. 
In this lab, you will use with Linear, which is the fastest and simplest simulation for basic circuits and systems. You 
will simulate Gain and Return Loss. Review these three videos: 

1. Introduction to Genesys:   
https://www.keysight.com/en/pc-1297125/genesys-rf-and-microwave-design-software?nid=-
34275.0.00&cc=US&lc=eng  

2. Filter Synthesis (Genesys Synthesis):   
https://youtu.be/6sWroyFNlS8 

3. Linear Simulation in Genesys:   
https://www.youtube.com/watch?v=DqNlMTSPQjA  

In subsequent labs, you will use RF System simulation to incorporate Multi-source signal sources and non-linear 
characteristics such as Intermodulation Products (IP3), Gain Compression and Saturation, and Harmonic Balance 
to predict harmonics, mixing products, and phase noise. 

 

 
  

https://www.keysight.com/en/pc-1297125/genesys-rf-and-microwave-design-software?nid=-34275.0.00&cc=US&lc=eng
https://www.keysight.com/en/pc-1297125/genesys-rf-and-microwave-design-software?nid=-34275.0.00&cc=US&lc=eng
https://youtu.be/6sWroyFNlS8
https://youtu.be/6sWroyFNlS8
https://www.youtube.com/watch?v=DqNlMTSPQjA


Lab 2: Filters (Solution)        RF Microwave Lab Courseware 

Keysight RF Microwave Circuit Design, Simulation and Measurement Courseware, 5G NR n3 37 

6.2.1 Synthesize the Lumped Element Filter 
1. Open Genesys software and create a new Schematic in your workspace. 

a. Select File > New or click the Start Page icon:   

b. Name it Genesys Lumped Synthesis. 

2. In the new window, select Tools > GENESYS Synthesis or go to Synthesize a new design and select 
Passive Filter and select OK.  

 
 

 
 

3. Name your filter Lab 2.3 Filter Design and click OK. 
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4. Select the following settings:  

a. Topology:  Minimum Inductor 

 
b. Settings:  190 MHz at -1 dB, and order = 5, Inductor Q = 200 (on Defaults tab) 

   
 

The filter result from the initial synthesis looks like this.  

 
 

4. Record Component Values in the table below.  

Instructor Answer: 

C1 L1 C2 L2 C3 

24.589pF 57.279nH 38.964pF 57.279nH 24.589pF 
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5. You now choose a high-Q air-core inductor, near 57.279nH. A 68nH 1515SQ-68NH from Coilcraft is near 
enough. You will want the filter to be tuned with the inductor coil turns spread just a little bit. This will allow 
a little tunability for later. Let’s assume a spreading that reduces the inductance to 63nH and recalculate 
the capacitors in Genesys. 

a. Double-click on each inductor to edit Properties, change its value to 63nH and Run Analyses.  

 

 
 

b. Then highlight the component(s), in this case the three capacitors in the schematic and click on the 
Variable Options icon in the Tune Window and select C1, C2, and C3 to be tuned using Standard 
Values. 

6. Before tuning you will notice the filter cutoff frequency drops substantially due to the change to 63 nH. Can 
you select new values, hitting the green Run Analyses icon at the top to return to a similar cutoff? Can you 
continue to tune to improve return loss in the passband? What values did you select?  

Record your component values and filter response.  

Instructor Answer: 

C1 L1 C2 L2 C3 

18pF 63nH 33pF 63nH 18pF 
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7. Normally, you would now move the design to ADS for layout and simulation using the following steps, but 
to save time, Keysight has created this for you and you may skip steps a, b, … below. 

a. First, save the workspace (Anywhere on your computer is fine. This is necessary before exporting.) 

b. File > Export Schematics to ADS.  

c. Open the ADS Workspace and open the schematic from Folder View. 

d. You can double-click a component to see its imported values. 

e. Save All. 

f. Open the schematic, verify that it looks as expected, and click Layout > Generate/Update 
Layout… to begin a PCB layout in ADS. 

Instructor Answer:  

When finished you may check your work by opening the pre-prepared solution by opening the file 
Lab2GENESYSworkspace.wsg in folder M1_L2. 
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6.2.2 Run Pre-prepared Inductor Simulations  
The ADS layout and simulations have been completed for you. From the ADS Main menu Unarchive… the file 
Lab2workspace_wrk.7zads from the folder M1_L2 to the root of the C:\ drive on your computer. 

NOTE You may be able to simply open the workspace directly if it has already been unarchived on 
the computer.  
 

 or  
 

 

 

1. Open the ADS Lab2workspace_wrk in the ADS workspace. From the folder view you will see: 

 

2. Note that the first folder 0_EMPro Components contains three subfolders each containing an  
model of a Coilcraft CC1515SQ-68NH inductor. Double-click a model to view it.    

CC1515SQ-68NH_v1 off-the-shelf 
CC1515SQ-68NH_v2 with the coils spread a bit 
CC1515SQ-68NH_v3 with the coils spread a little bit more 
 

 
 
It also contains a Parameterized Model CC1515SQ_1-8T. The Parameters may be varied. After reviewing 
these, it is recommended to close the files without saving. 

3. From the second folder 1_Inductor_Simulations, expand the cell and open the layout file for simulation of 
each of the three inductors: 

b_1_CC1515SQ-68NH_Sim off-the-shelf 
b_2_CC1515SQ-68NH_Sim with the coils spread a bit 
b_3_CC1515SQ-68NH_Sim with the coils spread a little bit more  
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4. Click the 3D EM Preview (or the multi-colored button Visualization) to see the layout to test the inductor.  

 
 

5. Observe the 3D model by rotating and zooming.  
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6. Open the Data Display window for the measurement of the inductor:   

1_Inductor_Simulations > b_1_CC1515SQ-68NH_Sim.dds 
7. The dataset converts S(1,1) to Z(1,1) according to: 

Z11 = 50*(1+S11)/(1-S11) 

It has modeled the reactance of the physical inductor as a frequency-varying inductor. 

X = 2πfL    L = X/2πf 

Thus, as the reactance varies with frequency due to parasitic capacitance between the turns of the coil, so 
does this model of inductance. 

8. Hover with your cursor over a frequency as near as possible to the cutoff frequency. 
 

 
 

9. Observe that the reactance becomes negative (capacitive) at 700 MHz. How will this phenomenon affect 
your filter? 

Instructor Answer:   

Little impact because it is well beyond the cutoff frequency. 

10. Open the layouts and 3D EM Preview or Visualization and datasets for the remaining two versions of the 
inductor:   
b_2_CC1515SQ-68NH_Sim the same inductor with the turns manually spread slightly 
b_3_CC1515SQ-68NH_Sim the same inductor with the turns manually spread slightly more 
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You may find it convenient instead to go back to the first folder 0_EMPro Components and double-click 
the physical inductor models to view their EMPro previews.  

1515SQ-68NH_v1 
1515SQ-68NH_v2 
1515SQ-68NH_v3 
1515SQ-68NH_wCoilCraft has v1 superimposed with the manufacturer’s physical model, showing a slight 
coil twist but the same length): 
 

 
 

11. Note differences. How does the L vary with the length of the inductor specifically spacing of the turns? 
Complete the table.  

L_nH initial L_nH spread L_nH spread more 

67 63 59 
 

Instructor Answer:   
Inductance decreases as the spacing between the turns increases. 
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6.2.3 Run the Pre-prepared Low Pass Filter Simulation  
1. Open the Low Pass Filter layout file under the cell: 2_Filter_Designs > LPF_5-Pole_Layout. This filter 

has used the simulation with inductor turns spread just enough to decrease its inductance to 63 nH:  
b_2_CC1515SQ-68NH_Sim.  

Here is the layout. 

 
2. Click the 3D EM Preview icon noted above to see the filter simulated in 3D.  
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3. From the EM Simulation Settings, click Launch EMPro and import this design.  

 
 

 
 

4. Grab a point with the mouse button and observe as you rotate the 3D image. 

5. If you have time, run the EM simulation (this may require several minutes) by clicking the green button 
shown below and name the output something other than LPF_5-Pole_Layout_v1. 

 
 
Examine the results (procedure in the previous lab). Why do they not show the designed LPF response? 

Instructor Answer:   

Only the inductors and lines were simulated, no capacitors. 
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6. Why is the filter laid out in this fashion? 

Instructor Answer:   

Mutual inductance is minimized by placing the inductors at right angles to each other. 

7. Open the Low Pass Filter schematic file under the cell:  Simulate_EM_LPF_5-Pole which integrates the 
emModel and the S-parameter dataset from the cell LPF_5-Pole_Layout. The capacitors are real 18, 33 
and 18 pF surface mount components: 

 
 

8. Click the Simulate icon shown above to generate the dataset (or just click the dataset).  
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9. Reopen the Genesys analysis schematic in Lab2GENESYSworkspace.wsg, right-click on 

, and export the .s2p file as shown below.  

An example data file from Genesys is provided. 

   
 

Lab 2.3 Filter 
Design_Analysis_Dat 
 

10. Then add the S-Parameters of the Genesys-synthesized circuit for comparison.   

 
11. What is the 1 dB cutoff frequency of the simulated filter?  How does it compare with the ideal response you 

calculated using GENESYS? Why is the cutoff frequency lower? 

Instructor Answer:   

The 1 dB cutoff frequency of the EM-model with real capacitors is less than 190 MHz due to parasitic 
capacitance from the inductor pads on the PCB to ground plane. The capacitance from the turns of the coil 
to the ground plane may have some additional effect.  

 
  



Lab 2: Filters (Solution)        RF Microwave Lab Courseware 

Keysight RF Microwave Circuit Design, Simulation and Measurement Courseware, 5G NR n3 49 

12. Try changing capacitors to return the cutoff frequency to the specified value. This is done by creating a new 
cell named Simulate_EM_LPF_5-Pole_v1 using Copy Cell.  What happened? 

Instructor Answer: 

C1 C2 C3  

15pF 27pF 15pF 

 
The values above increased the LPF cutoff to approximately 185 MHz but were not exactly the right ones 
since component choices were limited. This is common in practice. When you test the actual X-MWblock, 
you will notice that two capacitors may have been placed in parallel to achieve an optimum value. 

 
13. From the EM Simulation Settings, click Launch EMPro and import this design. 
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6.2.4 Open in EMPro to Understand Filter Response 
Open EMPro to examine the design using a 3D electromagnetic simulation. It will include inductor parasitic 
capacitances, mutual inductance, trace coupling, and other 3D effects, but not the surface-mount capacitors. 

Background Video of a similar design: (Time 2:52) Link: https://youtu.be/Z3dhIf1ruvc 

 

 

https://youtu.be/Z3dhIf1ruvc
https://www.youtube.com/watch?v=Z3dhIf1ruvc
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7 Measure the Performance of the Built Low Pass Filter 
Objective:  Measure the performance of the Lumper Element LPF and compare to the simulated design. 

For the purposes of this lab, the filter has been provided so you will start with a pre-built filter and your objective will 
be to measure (and later tune) it’s performance. You will evaluate the SAW filter against the required Intermediate 
Frequency (IF) filter specification. Fill out the table below as you take the measurements.  

7.1 Procedure to Measure the Filter Performance 
1. Disconnect the SMA cables from the probe. 

2. Press Frequency > Start and set to 30 kHz and Stop to 18 GHz (Full Span) and take the key 
measurements. You should re-cal or recall the calibrated FieldFox state WIDE created in Appendix A in the 
Transmission Line lab. 

3. Ensure the X-MWblock for the Lumped Element Filter XM-B1F4-1204D, PCB #0976 is attached to the 
plate and attach X-MWprobes to both sides. Measure S11 and S21. 

 
Figure 9. Lumped Element Filter Layout View 

 
Figure 10. Lumped Element Filter with X-MWprobes 

4. Press Frequency > Start and set to 50 MHz and Stop to 350 MHz to zoom into the pass band and 
remeasure. You should re-cal or recall the calibrated FieldFox state 168.5 created in Appendix A in the 
Transmission Line lab. 

5. Record results on the table below and download and compare the measure versus the manufacturer’s S-
Parameters as in the previous task. 
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Measurement Results 
Instructor Answer:  

Band Pass 
Filter 

Center 
Frequency CF 

Insertion 
Loss at CF 

Loss at 156 
MHz re CF 

Loss at 181 MHz 
re CF 

Rejection at 
337 MHz 

Requirement 168.5 MHz < 10 dB < 1 dB < 1 dB > 30 dB 
XM-A3V3-
0404D LPF, not BPF < 1 dB 0.2 dB 0.2 dB 28 dB 

 
1. Would you choose this filter to provide 30 dB rejection above 337 MHz (2 x 168.5)? 

Instructor Answer:  

Yes, but only up to 3.6 GHz and note that it did not quite achieve 30 dB rejection at 337 MHz. 
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2. How might this part’s insertion loss affect the design of the single mixer converter? 

Instructor Answer:  

The insertion loss is very low and should not be a problem. 
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7.2 Plot Synthesized, Simulated and Measured Data on the Same Plot 
1. Reopen the Genesys analysis schematic in Lab2GENESYSworkspace.wsg, right-click on 

, and export the .s2p file as shown below.  

Example data files from Genesys and from the FieldFox are provided. 

   
 

Lab 2.3 Filter 
Design_Analysis_Dat

LumpedElementMe
asured.s2p  

 
2. Reopen the ADS workspace Lab2workspace_wrk and your Simulate_EM_LPF_5-Pole_v1 data display, 

convert with the Data File Tool… and add the Genesys-simulated and measured .s2p files to the graph 
for comparison. A sample measured file is provided. Why does the measured filter have a higher cutoff 
than the ideal or simulated? Discuss your results.  

Hint:  Use markers with .  
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Instructor Answer: 

The added markers highlight the three traces: 

m1:  ADS EM Simulation with 3D-simulated inductors and circuit traces 

m2:  Genesys Ideal Simulation with Lumper Element models only 

m3:  Measured 

The measured filter’s cutoff may be higher that the ideal or simulated because the inductor coils may be 
spread too much (by the previous student?) producing a lower inductance and hence a higher cutoff 
according to the simple 2-pole equation for cutoff.  

𝑓𝑓𝑓𝑓 =
1

2𝜋𝜋√LC
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Same plot with higher resolution. 
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7.3 Tune the LPF by Hand 
1. Ensure that you are displaying both S21 and S11 as large as possible on the same display effects. 

2. Use a non-metallic pick (such as a toothpick) to gently and very-slightly spread the coils of the two 
inductors in the filter while watching the FieldFox display. 

3. Press the coils closer together using two picks. 

4. Describe the changes of the filter response. 

Instructor Answer: 

The measured filter’s cutoff increases when the inductor coils are spread to produce a lower inductance and 
hence a higher cutoff. The cutoff decreases when the two ends of the coil are pressed together. 

7.4 Select the IF Filter 
Although the lumped element filter has better insertion loss and may have sufficient rejection at 337 MHz, 
its size and cost may make it unsuitable for use in mass-produced mobile systems. You will choose the 
second-best filter, the SAW filter, for the 5G n3 Receiver. 

Since this filter has significantly higher insertion loss, how will the radio design proceed? 

Instructor Answer: 

1. Make up for the extra loss in the subsequent IF and digital filters 

2. The mixing products at mfc-nflo, where m and n = 2, 3, …, the second, third, and so forth may fold back 
to near zero frequency after the IF filter. For this reason, the IF filter will have to reject DC which is a 
characteristic of the BAW but would have required a dc-blocking capacitor in front of or after the 
lumped element filer. 

3. The IF filter characteristic limits the noise and can perform the anti-alias function for the sampling ADC 
after the IF filter. 
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Post-Lab Writeup 
1. Provide screen captures of all measured data in a single document 

2. Label each plot according to the lab step where it was captured. 

3. If your results do not match your expectations, explain why. 
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Appendix A: FieldFox Calibration 
Please see Appendix in the first Lab Sheet. 
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Appendix B: Saving Data on the FieldFox 
Please see Appendix in the first Lab Sheet. 
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